1
0
Fork 0
nixos/config/fonts.nix

47 lines
1.0 KiB
Nix

{
pkgs,
lib,
config,
...
}:
with lib;
mkIf (elem "fonts" config.machine.conffiles) {
fonts = {
fontDir.enable = true;
enableGhostscriptFonts = true;
fontconfig = {
enable = true;
# deprecated (will eventually be completely removed)
# ultimate.enable = true;
includeUserConf = false;
};
packages = with pkgs; [
arphic-ukai
arphic-uming
crimson
corefonts # Microsoft free fonts
dejavu_fonts
font-awesome
inconsolata # monospaced
inter
manrope
montserrat
nerdfonts
noto-fonts
noto-fonts-cjk
noto-fonts-emoji
noto-fonts-extra
powerline-fonts
source-han-sans-japanese
source-han-sans-korean
source-han-sans-simplified-chinese
source-han-sans-traditional-chinese
# source-sans-pro
symbola
ubuntu_font_family
wqy_microhei
wqy_zenhei
];
};
}