nixos/machines/Sheol/options.nix
2024-11-20 21:23:36 +01:00

46 lines
698 B
Nix

{ ... }:
{
imports = [
../../options/copySysConf.nix
];
config.machine = {
allowUnfree = true;
hostName = "Sheol";
networkD = {
enable = true;
waitOnline = false;
};
administrators = [
{
name = "derped";
id = 1337;
}
];
conffiles = [
"etcfiles"
"etcvars"
"zsh"
];
pkgs = [
"base"
];
services = [
"desktop"
"desktop::sway"
# "kodi"
"mullvad"
"openssh"
"pipewire"
"uxplay"
];
firewall = {
enable = true;
allowPing = true;
};
};
config.system.copySysConf = {
enable = false;
addToNixPath = false;
};
}