18 lines
291 B
Nix
18 lines
291 B
Nix
{
|
|
lib,
|
|
config,
|
|
...
|
|
}:
|
|
|
|
lib.mkIf (lib.elem "nvim::gen" config.machine.pkgs) {
|
|
programs.nvim-lazy.lazyPlugins = [
|
|
{
|
|
lazy = true;
|
|
short = "David-Kunz/gen.nvim";
|
|
cmd = [ "Gen" ];
|
|
opts = {
|
|
model = "deepseek-coder:1.3b-base-q4_0";
|
|
};
|
|
}
|
|
];
|
|
}
|